This article describes steps to activate a Talk2M Pro account after the trial period has expired.
APPLICABLE PRODUCTS
This article is applicable to:
- Talk2M Pro Account
ISSUE
After the Pro trial period has expired, the Talk2M account defaults back to its free state. This article shows the steps needed to permanently activate the Talk2m account after the trial period has expired.
POSSIBLE CAUSES
In order to permanently activate the Talk2M Pro account, please follow the steps below:
- End-customers, please reach out to your distributer and provide the following information:
- Account name
- Reference Number
- Distributors, please reach out to HMS Sales Team with the end-customer's account information and instructions will be sent to submit a PO.
NOTE: Please allow 48 hours after the PO is submitted to have the account set back to Pro permanently.
ADDITIONAL INFO
How to find my Talk2m Account Reference Number? – HMS Support Portal (hms-networks.com)